HihoCoder1054

题目2 : 滑动解锁

描述

滑动解锁是智能手机一项常用的功能。你需要在3x3的点阵上,从任意一个点开始,反复移动到一个尚未经过的”相邻”的点。这些划过的点所组成的有向折线,如果与预设的折线在图案、方向上都一致,那么手机将解锁。两个点相邻当且仅当以这两个点为端点的线段上不存在尚未经过的点。此外,这条折线还需要至少经过4个点。为了描述方便,我们给这9个点从上到下、从左到右依次编号1-9。那么1->2->3是不合法的,因为长度不足。1->3->2->4也是合不法的,因为1->3穿过了尚未经过的点2。2->4->1->3->6是合法的,因为1->3时点2已经被划过了。

作为一个爱逛知乎的好少年,小Hi已经知道一共有389112种不同的解锁方案。不过小Hi不满足于此,他希望知道,当已经瞥视到一部分折线的情况下,有多少种不同的方案。

遗憾的是,小Hi看到的部分折线既不一定是连续的,也不知道方向。例如看到1-2-3和4-5-6,那么1->2->3->4->5->6,1->2->3->6->5->4,
3->2->1->6->5->4->8->9等都是合法的方案。

输入

第一行包含一个整数T(1 <= T <= 10),代表测试数据组数。

每个测试数据第一行是一个整数N(0 <= N <= 8),代表小Hi看到的折线段数目。

以下N行每行包含两个整数X, Y (1 <= X, Y <= 9),代表小Hi看到点X和点Y是直接相连的。

输出

对于每组数据输出合法的方案数目。

样例输入

3
0
8
1 2
2 3
3 4
4 5
5 6
6 7
7 8
8 9
4
2 4
2 5
8 5
8 6

样例输出

389112
2
258

分析:

思路:

Code:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
#include <stdlib.h>
#include <stdio.h>
#include <string.h>
#include <algorithm>


using namespace std;

int rs; // total legal solution
int totalEdgeCount; //total edge count in every input data
int record[10][10]; //store illegal edge
int data[10][10]; //store edge from input data
int pointCount; //total point count in result
int vis[10]; // is visited

void init() {
record[1][3] = record[3][1] = record[1][7] = record[7][1] = 1;
record[1][9] = record[9][1] = record[3][7] = record[7][3] = 1;
record[9][3] = record[3][9] = record[9][7] = record[7][9] = 1;
record[2][8] = record[8][2] = record[4][6] = record[6][4] = 1;
}

void depSearch(int leftPoint, int currPointCount, int currEdgeCount) {
if (currPointCount == pointCount && currEdgeCount == totalEdgeCount) {
rs++;
return;
}

for (int i = 1; i < 10; i++) {
if (!vis[i]) {
if (record[leftPoint][i] && !vis[(leftPoint + i) / 2]) continue;
vis[i] = 1;
if (data[leftPoint][i])
depSearch(i, currPointCount + 1, currEdgeCount + 1);
else
depSearch(i, currPointCount + 1, currEdgeCount);
vis[i] = 0;
}
}
}

int main() {
int n, m, a, b;
scanf("%d", &n);

init();
while (n > 0) {
scanf("%d", &m);

memset(vis, 0, sizeof(vis));
memset(data, 0, sizeof(data));

for (int i = 0; i < m; i++) {
scanf("%d %d", &a, &b);
data[a][b] = data[b][a] = 1;
}

rs = 0;
totalEdgeCount = m;
for (pointCount = max(4, m + 1); pointCount < 10; pointCount++) {
for (int i = 1; i < 10; i++) {
vis[i] = 1;
depSearch(i, 1, 0);
vis[i] = 0;
}
}

printf("%d\n", rs);
n--;
}

return 0;
}