POJ1006

Description
Some people believe that there are three cycles in a person’s life that start the day he or she is born. These three cycles are the physical, emotional, and intellectual cycles, and they have periods of lengths 23, 28, and 33 days, respectively. There is one peak in each period of a cycle. At the peak of a cycle, a person performs at his or her best in the corresponding field (physical, emotional or mental).

For example, if it is the mental curve, thought processes will be sharper and concentration will be easier. Since the three cycles have different periods, the peaks of the three cycles generally occur at different times. We would like to determine when a triple peak occurs (the peaks of all three cycles occur in the same day) for any person. For each cycle, you will be given the number of days from the beginning of the current year at which one of its peaks (not necessarily the first) occurs. You will also be given a date expressed as the number of days from the beginning of the current year. You task is to determine the number of days from the given date to the next triple peak. The given date is not counted. For example, if the given date is 10 and the next triple peak occurs on day 12, the answer is 2, not 3. If a triple peak occurs on the given date, you should give the number of days to the next occurrence of a triple peak.

Input
You will be given a number of cases. The input for each case consists of one line of four integers p, e, i, and d. The values p, e, and i are the number of days from the beginning of the current year at which the physical, emotional, and intellectual cycles peak, respectively. The value d is the given date and may be smaller than any of p, e, or i. All values are non-negative and at most 365, and you may assume that a triple peak will occur within 21252 days of the given date. The end of input is indicated by a line in which p = e = i = d = -1.

Output
For each test case, print the case number followed by a message indicating the number of days to the next triple peak, in the form:

Case 1: the next triple peak occurs in 1234 days.

Use the plural form “days” even if the answer is 1.

Sample Input
0 0 0 0
0 0 0 100
5 20 34 325
4 5 6 7
283 102 23 320
203 301 203 40
-1 -1 -1 -1

Sample Output
Case 1: the next triple peak occurs in 21252 days.
Case 2: the next triple peak occurs in 21152 days.
Case 3: the next triple peak occurs in 19575 days.
Case 4: the next triple peak occurs in 16994 days.
Case 5: the next triple peak occurs in 8910 days.
Case 6: the next triple peak occurs in 10789 days.

初步分析

  首先分析即可得到公式:N+d = p+23*x = e+28*y = i+33*z。这里x、y与z都不可能求出来,可以这样转换一下思路:T=N+d 除以23余p,且除以28余e,且除以33余i(最后要求的那个N只需T-d就好了)。

  类似这样的题目(除以一个数余数是多少这样的)就需要用到“中国剩余定理”,不知道的话,解这道题可能比较困难。

中国剩余定理

  在《孙子算经》中有这样一个问题:“今有物不知其数,三三数之剩二(除以3余2),五五数之剩三(除以5余3),七七数之剩二(除以7余2),问物几何?”这个问题称为“孙子问题”,该问题的一般解法国际上称为“中国剩余定理”。具体解法分三步:

  1. 找出三个数:从3和5的公倍数中找出被7除余1的最小数15;从3和7的公倍数中找出被5除余1的最小数21;最后从5和7的公倍数中找出除3余1的最小数70。

  2. 用15乘以2(2为最终结果除以7的余数),用21乘以3(3为最终结果除以5的余数),同理,用70乘以2(2为最终结果除以3的余数),然后把三个乘积相加(15*2+21*3+70*2)得到和233。

  3. 用233除以3,5,7三个数的最小公倍数105,得到余数23,即233%105=23。这个余数23就是符合条件的最小数。

这里用了一个小技巧,例如:并非从5和7的公倍数中直接找一个除以3余2的数,而是先找一个除以3余1的数,再乘以2。

对于这道题目,可按下面步骤解决:

  1. 首先,求满足除以23余1,整除28,且整除33的三个条件的最小数,发现是5544(设为A)。

  2. 然后,求满足除以28余1,整除23,且整除33的三个条件的最小数,是14421(设为B)。

  3. 接着,求满足除以33余1,整除23,且整除28的三个条件的最小数,是1288(设为C)。

  4. 最后,5544 * p + 14421 * e + 1288 * i 就一定是三个周期的下一个巅峰了,只不过不一定是最小值。如果要求最小值,只需取除以(23,28,33)的最小公倍数。

这里解释一下上面那么做的原因是什么:

  1. 一个数X除以23余1,Y除以23整除,那么(X+Y)除以23依旧是余1的。即一个数加上整除x的数,其除以x的余数是不变的。所以:

    • 对于23来说,A+B+C余数还是1,因为B和C是整除23的。

    • 对于28来说,A+B+C余数还是1,因为A和C是整除28的。

    • 对于33来说,A+B+C余数还是1,因为A和B是整除33的。

  2. A除以23余1,A*c除以23就余c*1,即余c了。所以得到结论就是:

    • 5544*p除以23就余p,除以28整除,除以33整除。

    • 14421*e除以28余e,除以23整除,除以33整除。

    • 1288*i除以33余i,除以23整除,除以28整除。

代码如下:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
#include <iostream>
#include <algorithm>
#include <cmath>
#include <vector>
#include <string>
#include <cstring>
#pragma warning(disable:4996)

using namespace std;

int main() {
int a, b, c, d, j = 1;
while (cin >> a >> b >> c >> d) {
if (a + b + c + d == -4)
break;

cout << "Case " << j;
j++;
cout << ": the next triple peak occurs in ";
int temp = (5544 * a + 14421 * b + 1288 * c - d + 21252) % 21252;
if (temp == 0) {
cout << 21252;
}
else
cout << temp;
cout << " days." << endl;
}

//system("pause");
return 0;
}